Monday, 1 February 2010

Error – Exchange 2007 server on which an address list service is active cannot be found

In the process of configuring a Companyweb SharePoint library (previous blog post) for a client’s copier and scanner PDFs, we ran into this strange error when creating the e-mail contact in Exchange:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00

Scan ToEmail
Failed

Error:
An Exchange 2007 server on which an address list service is active cannot be found.

Exchange Management Shell command attempted:
New-MailContact -ExternalEmailAddress 'SMTP:scans@companyweb' -Name 'Scan ToEmail' -Alias 'scans' -OrganizationalUnit sbsdomain.local/MyBusiness/Users/SBSUsers' -FirstName 'Scan' -Initials '' -LastName 'ToEmail'

Elapsed Time: 00:00:00

The only clue to the source of the problem was found here:

The writer indicates that the source is the Microsoft Exchange System Attendant service not running.

Sure enough:

image

The service was indeed not running.

Now, why the service was not running in the first place is an unknown other than perhaps it did not start up after the Exchange 2007 Service Pack 2 installation. We will monitor the rest of our SP2 installs to see if this behaviour is consistent.

As a just in case, we did the following:

image

We changed the Take No Action to Restart the Service.

Once the service was started, we were greeted with the following after running the New Mail Contact wizard:

Summary: 1 item(s). 1 succeeded, 0 failed.
Elapsed time: 00:00:00

Scan ToEmail
Completed

Exchange Management Shell command completed:
New-MailContact -ExternalEmailAddress 'SMTP:scans@companyweb' -Name 'Scan ToEmail' -Alias 'scans' -OrganizationalUnit sbsdomain.local/MyBusiness/Users/SBSUsers' -FirstName 'Scan' -Initials '' -LastName 'ToEmail'

Elapsed Time: 00:00:00

Philip Elder
MPECS Inc.
Microsoft Small Business Specialists
Co-Author: SBS 2008 Blueprint Book

*Our original iMac was stolen (previous blog post). We now have a new MacBook Pro courtesy of Vlad Mazek, owner of OWN.

Windows Live Writer

2 comments:

Anonymous said...

Link helped me out for sure..

Anonymous said...

Also found this issue related to user with large Security Token. Removed unrequired Security groups and this resolved issue for the user account.