Wednesday, 13 June 2012

APC AP9630 Management Card: Error: The application was not able to load.

We have an APC UPS Network Management Card 2 that decided to go South on us:


Error: The application was not able to load.

You are attempting to access an APC device.

There was a problem loading the application. Please login to the device via telnet for more details.

Telnet told us absolutely nothing with the event logs being empty. All we saw was the exclamation mark behind the “A”.

E000: Success
Name:     Unknown
Contact:  Unknown
Location: Unknown
DateTime: 06/13/2012:11:52:05
User:     Administrator
Up Time:  0 Days 0 Hours 13 Minutes
Stat:     P+ N4+ N6+ A!
Bootmon:  bootmon:v1.0.2
AOS:      aos:v5.1.7
App:      sumx:v5.1.7

APC Support page:

So, time to flash the firmware.

Firmware download page:


We ran the flash in Windows 7 with no errors but the web application still failed to load:


After about four or five minutes we saw:


But, we still had the error. We called into APC Support to see if we could get any further.

They had us run the Windows version of the update from a Windows XP machine. It still failed.

While on the phone with the tech support folks we ran the following commands via Telnet (Tera Term):

  1. reboot [Enter]
  2. yes [Enter]

It still failed to come back online. So, we went into the following steps:

  1. resetToDef –p keepip [Enter]
  2. yes [Enter]
  3. reboot [Enter]
  4. yes [Enter]

With absolutely no results we then had one more option (Nuke and Pave):

  1. format [Enter]
  2. yes [Enter]
  3. reboot [Enter]
  4. yes [Enter]

Note that we used Tera Term via Serial connection to complete the final command set to format as the IP address info would be lost.

Once the card finished its final reboot we were able to log in and see the status A+ for the web server services.

American Power Conversion               Network Management Card AOS      v5.1.7
(c) Copyright 2010 All Rights Reserved  Smart-UPS & Matrix-UPS APP       v5.1.7
Name      : Unknown                                   Date : 05/16/2011
Contact   : Unknown                                   Time : 00:17:48
Location  : Unknown                                   User : Administrator
Up Time   : 0 Days 0 Hours 14 Minutes                 Stat : P+ N4+ N6+ A+

We then used the tcpip command to set the IP, subnet, and gateway. Once the card rebooted we were into the web console successfully!

In the end the best possible solution after running a firmware update and having it fail is to nuke and pave.

Philip Elder
Microsoft Small Business Specialists
Co-Author: SBS 2008 Blueprint Book

*Our original iMac was stolen (previous blog post). We now have a new MacBook Pro courtesy of Vlad Mazek, owner of OWN.

Windows Live Writer


Anonymous said...

Thanks alot for the great article. We had exactly the same problem today. After this steps it works again properly!

Regards from Switzerland

Anonymous said...

Thanks alot for the great article. We had exactly the same problem today. After this steps it works again properly!

Regards from Switzerland

Anonymous said...

I had the same issue. I ran the update again and it fixed itself.

Anonymous said...

These instructions assisted me with an AP9631 that had just been upgraded to the 6.0.6 firmware. I had to completely wipe and reset, but it worked. Luckily, I had a DHCP reservation already created, so I was able to get back to the web interface after the wipe/reset.


Anonymous said...

Glad I found this. The instructions didn't work for me, I ended up downloading the latest firmware and updating via that, but at least it reminded me to set a reservation before going any further.

Anonymous said...

actually it is much easier to get the two firmware files (the AOS and SUMx) file from APC for the firmware version you are going to. once you have both FTP to the card and upload them one at a time. the card will reboot after each upload. from you error message it look like the AOS file on the card was corrupted. but it could have been either.
you can do this by opening a windows explorer window and typing in FTP://(ip address of the card) it will ask you for a user and pass once in there just copy the files over or you can open a CMD window and type FTP (ip address) once there log into the card and then type bin (for binary) then put and the filename you are uploading. I have dealt with this many times

by doing this you do not lose any network settings.

Anonymous said...

Thank goodness for the post on 03 February, 2016 05:07

This was a lifesaver; the documentation from the APC site is basically worthless when it comes to updating firmware on these things.

Thank you, whoever you are.

davidson imagery said...

Hi Guys, when issuing reboot command and firmware updates etc, does this actually affect the operation of the UPS load? I have this issue with a UPS and have active production load that I can't interrupt.


Philip Elder Cluster MVP said...


We've not seen the UPS kick a power cycle or shut down during a firmware update.