Tuesday, 12 August 2008

Terminal Server not showing up in Remote Web Workplace

This one is via the SBSC SBS Newsgroup: After setting up a new Terminal Server on the SBS2K3 network, the "Connect to my Application Server" link is not appearing in RWW.

Remotely edit the SBS and Terminal Server's registry and look for the keys:
  • On SBS:
    • HKLM\Software\Microsoft\SmallBusinessServer\RemoteUserProtal\
      KWLinks\AppTS=1 (wrapped on purpose)
  • On the TS:
    • HKLM\System\CurrentControlSet\Control\Terminal Server\TSEnabled = 1
    • HKLM\System\CurrentControlSet\Control\Terminal Server\TSAppCompat = 1
If one or both of the keys are not present, create them with the values indicated. If the value for the key is anything but "1", then edit the key to change that value.

We need to make sure that the Remote Registry service on the TS box is running, and that the firewall has the appropriate ports open to serve TS or the firewall is off altogether.

Philip Elder
Microsoft Small Business Specialists

*All Mac on SBS posts are posted on our in-house iMac via the Safari Web browser.


Anonymous said...

Awesome thanks :).

Our win2008 TS was missing the TSEnabled dword.

It had a dword TSUserEnabled but it still needed the TSEnabled.

Thanks again,

NOTGraham said...

This is really useful.
Trying to get my TS 2008 box published on RWW. I can get it to appear now, just not connected!

Firewall is off, and I think everything is correct, but I am now tearing my hair out trying to work out whats going on and denying me access. My connection error is

VBScript: Remote Desktop Disconnected
An internal error has occurred.

Which isn't the most helpful :-(

Anonymous said...


On SBS it looks like the menus you will see in RWW are different for administrators.

Try logging on as a test user without admin rights and it will probably be there.