Tuesday, 17 March 2009

SBS 2008 – Troubleshooting and the SBS POP3 Connector

We have a client situation where the POP3 Connector is required.

Once set up, the POP3 Connector did not start pulling e-mail in right away.

When we ran the POP3 Connector retrieve process manually, we received:

09-03-17 SBS 2008 - POP3 Connector - 2 - mail was retrieved with errors

Windows SBS POP3 Connector

POP3 e-mail was retrieved with errors.

The Windows SBS POP3 Connector service encountered one or more problems while retrieving your POP3 e-mail. View the event log for more information.

To check the status on any SBS 2008 component, there is a folder in the Event Viewer with an SBS specific log set in it:

09-03-17 SBS 2008 - POP3 Connector - 4 - Event Logs ID 207 Error

Microsoft-Windows-Small Business Server/Operational Log

So, we head into the log to find out just what is happening. It turns out that the error has to do with either the username or password.

When we brought up the user’s POP3 Connector properties, the username was correct, so there must have been two left thumbs typing in the password! :)

After making sure that the password was indeed correct, we ran a manual receive again and this time we received:

09-03-17 SBS 2008 - POP3 Connector - 3 - mail was retrieved successfully

Windows SBS POP3 Connector

The POP3 e-mail was retrieved successfully. 

Further POP3 Connector troubleshooting:

Philip Elder
Microsoft Small Business Specialists
Co-Author: SBS 2008 Blueprint Book

*All Mac on SBS posts will not be written on a Mac until we replace our now missing iMac! (previous blog post)

Windows Live Writer


Chris Knight said...

It's this type of error reporting that annoys me.

For a product targeted at SMB, how difficult would it have been to bubble up the Event Log error message into the dialog?

How many admin hours have been wasted so far by techs opening up Event Viewer to look at an error message that could have been bubbled up to the dialog?

Anonymous said...

re: POP3 on Win7

i have installed TBird email client -- my question now really centers on since i've installed the POP3 via download.live.com on a Win7 machine - how do i start the POP3 server -- or how do i confirm a POP3 server is running?

i'm not receiving email in my TBird inbox -- i'm trying to trouble shoot why.... utimately i need to receive event-driven alerts into this inbox... i'm open to any troubleshooting ideas...


Philip Elder SBS MVP said...


Q1: POP3 on an e-mail client is set in the E-mail Accounts (Outlook). Not being familiar with TBird, I am not sure where those settings would be.

Q2: Again, I do not work with TBird for e-mail clients. So, unfortunately I am unable to help you out with this one. Perhaps a forum via the product vendor?



r4 revolution said...

Does this happen in every mail server? I use 4 different servers in my outlook account. Please giver more information.

Anonymous said...

Thankyou,Thankyou,Thankyou - Once again the Microsofts Descriptive error machine working overtime!.

Wouldnt of sorted it without the advice, especially when i had 1.85Gb left...

Thankyou Again