Tuesday, 28 October 2008

Vista and Server 2008 KB957200 - Reliability Update?

These updates showed up in our SBS 2008 Updates Console:


Update for Windows Vista (KB957200)

Click through to the Microsoft Knowledgebase site for the update and we get a 404.

KB Article Not Found

Do a search on Microsoft's download site and we do get results for KB957200 for all flavours of Windows with a release date of October 26th though.

Before releasing this one to Vista or Windows Server 2008 including our SBS 2008 box, we would really like to see some release notes!

After synchronizing one of our SBS 2003 R2 Premium boxes with WSUS v3 installed the updates did not appear. Hmmm ... strange.

UPDATE: We are declining the update until such time as Microsoft gets the Knowledgebase article live. We need to make sure we know what exactly will be addressed by this update.

UPDATE 2008-10-30: The Microsoft Knowledgebase Article is live: Windows Error Reporting does not function correctly when it is running in a "Windows on Windows 64" (WoW64) configuration on a Windows Vista SP1-based or Windows Server 2008-based computer.

Philip Elder
MPECS Inc.
Microsoft Small Business Specialists

*All Mac on SBS posts are posted on our in-house iMac via the Safari Web browser.

8 comments:

Anonymous said...

I'd just installed KB957200 on my PC running Vista Ultimate 64bit, after installation I couldn't connect to the internet.
After uninstalling KB957200 everything seems to be OK.

Anonymous said...

I've just installed KB957200 on my PC running Vista home premium. After installation Vista seems to run like it is on fire, and everything seems to be fully functional.

Anonymous said...

I've installed KB957200 on my Vista Ultimate 64bit without any problems.

Philip E. said...

Thank you all for the feedback!

So far, one improvement, one choke, and one without problems.

Thanks for that folks!

Philip

Anonymous said...

I downloaded the update too and since then my internet is having trouble loading some websites (Vista Home Premium). I removed the update today and internet is working again.

Anonymous said...

I've had the same problem after installing this update for vista. pc is talking to the wireless router, but not the outside world. after uninstalling, everything is fine. Can I restrict Vista from downloading this update?

Anonymous said...

(same one as the first poster)
A few days ago I've re-installed the updated, and everthing seems to be working fine. (First I also had the problem that my laptop was not connected to the internet but did have a fuctioning connection to the router)

Philip E. said...

Thank you all for your feedback.

We appreciate the real-world experiences.

After your feedback, and Microsoft's subsequent release of the Knowledgebase article we released the update to our labs and internally. We did not have any issues, so we released it on our client's WSUS and so far so good.

Philip